[nos-bbs] JNOS 2.0k.3B compiling issues

Langelaar maiko at pcsinternet.ca
Thu Sep 26 15:23:39 EDT 2019

Going back a release is a big pain and lots of work for some folks.

Unless there are other non-JNOS issues people have run into.

Let me get a VM going and I'll get this fixed as soon as I can.


On 09/26/2019 02:21 PM, James Smith wrote:
> Ed,
>   That would be the "Buster" release, right?
>   A number of us have the same problem on the Raspberry Pi, same 
> error, no fix that we have found except to go back to the earlier 
> Raspbian release "Stretch". Something changed in this Debian release 
> and I haven't found it yet.
>   I think there was a library change, but I just haven't taken the 
> time to dig through the Debian source tree to find what might have 
> changed.
> Regards,
> Jim N8AVX
> On Thu, Sep 26, 2019 at 3:12 PM Ed Coates <edcoates at gmail.com 
> <mailto:edcoates at gmail.com>> wrote:
>     Hi everyone!
>     I'm trying to compile  JNOS on a Virtualbox VM running Ubuntu
>     19.04.  I've rsync'd the JNOS source code and copied the files
>     from the 2.0k.3 directory into the main directory and compiled
>     it.  I originally ran into some problems when it was compiling the
>     tun.c file.  I found an thread last month from Maiko that listed
>     an alternate tun.c file to use and that worked, but at the end of
>     the compile, while it's linking the binary jnos, I run into this error
>      gcc -DUNIX -g3   -DDEBUG -Wall -o jnos main.o config.o version.o
>     session.o \
>     jheard.o clients.a servers.a hfdd.a net.a internet.a net.a netrom.a \
>     unix.a ax25.a aprs.a dump.a ppp.a bootp.a inp.a j2curses.a \
>     -lncurses  -lcrypto -lcrypt
>     /usr/bin/ld: net.a(j2pwrtns.o): in function `j2setkey':
>     /usr/src/jnos/j2pwmgr/j2pwrtns.c:68: undefined reference to `setkey'
>     /usr/bin/ld: net.a(j2pwrtns.o): in function `j2userpasswd':
>     /usr/src/jnos/j2pwmgr/j2pwrtns.c:185: undefined reference to `encrypt'
>     collect2: error: ld returned 1 exit status
>     make: *** [makefile:156: jnos] Error 1
>     any ideas on the cause of the issue and how to fix it?
>     Thanks,
>     Ed
>     _______________________________________________
>     nos-bbs mailing list
>     nos-bbs at lists.tapr.org <mailto:nos-bbs at lists.tapr.org>
>     http://lists.tapr.org/mailman/listinfo/nos-bbs_lists.tapr.org
> _______________________________________________
> nos-bbs mailing list
> nos-bbs at lists.tapr.org
> http://lists.tapr.org/mailman/listinfo/nos-bbs_lists.tapr.org

More information about the nos-bbs mailing list