[aprssig] TNC2 FoxDigi - COM problem

Chris Moulding chrism at crosscountrywireless.net
Sat Jan 15 05:17:36 EST 2011

Hi Alexandru,

The firmware for the Fox Digi uses the original code written by Bob,
WB8WGA for his 2005 article about a Modemless TNC in QEX magazine.

Bob wrote the code for an packet TNC with a simple APRS facility but
didn't include the functions to enable it to work with UI-View.

When I developed the APRS TNC Digi Tracker I worked on Bob's firmware
for 18 months making a total of 3370 changes and added several functions
to allow it to work with UI-View as well as many other improvements
including much improved decoding with noisy signals, improved GPS code
allowing digipeating while mobile, status beacon every five position
beacons, power up protection, brown out protection, code and user data
protection with intermittent power supplies, a Digi All feature and many
other bug fixes and improvements.

Although the Digi Tracker has now gone well beyond the original simple
hardware design with receive audio filtering and processing, built in
GPS receiver and a new USB version out next month I can still provide
pre-programmed chips with a version of the revised firmware that will
work with a Fox Digi or the original WB8WGA design to provide all the
new firmware features including operation with UI-View.

Contact me direct if you are interested.


Chris, G4HYG

Chris Moulding
Cross Country Wireless Ltd
7 Thirlmere Grove, Bolton, Lancs, BL4 0QB, UK
Tel/fax: +44(0)1204 410626
Mobile:  +44(0)7752 391908
Website: http://www.crosscountrywireless.net
Company registered in England and Wales number: 7431559

On 15/01/11 06:05, alexandru wrote:
> hi for all, 
>  i make 2 pcs. TNC with PIC16F88 after FOX DIGI schematic, and MAX232
> for serial connection.
>   When I try to connect with ui-view, fail, I look frame error on com
> 1; if I give the command display, show me the settings after a few seconds.
>  So there is a delay on the RX line, because if I connect the
> modem, my message appears instantly "Modemless ....."  that's why I can
> not make any connection in the UI-View, I guess.
>  has anyone encountered this symptom?
> P.S.
> I tried a USB 2 COM adapter, in this case, I only show strange
> characters in terminal line.
> just happens to mention that both TNC, the scheme is fair, just and hardware
> _______________________________________________
> aprssig mailing list
> aprssig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/aprssig

More information about the aprssig mailing list