[nos-bbs] netrom related crashes (INP)

Maiko (Personal) maiko at pcsinternet.ca
Fri Sep 30 14:00:16 EDT 2022

It's my INP code, pretty sure of it. All the GDB dumps are landing
in the middle of the INP2001 defined code - very old, ported from
some original linux code courtesy of ideas and code snippets from
work done by PE1RXQ in a linux 2.6.4 kernel patch, back in 2005 ?

Quite honestly I had little to no experience way back when in knowing 
how it all worked. It was a linux to JNOS port essentially. I tried to
fix the original implementation as well. It was always READ ONLY, and
I never had JNOS broadcast INP3, only receive it - since I was scared
of corrupting the NETROM infrastructure that I was tied into.

UNTIL such time I am able to rewrite it, I would suggest to all :

  #undef INP2011

Unless it's perfectly stable for you, and/or you are getting some
type of benefit from running the 'start inp' service (hi Bob) :]

And yes I do know BPQ has implemented some type of INP support.


On 2022-09-27 11:42 a.m., maiko at pcsinternet.ca wrote:
> Getting a lot lately, all netrom related, no idea why ...
> Anyone else getting 'tired' of this ?
> Maiko / VE4KLM

More information about the nos-bbs mailing list