[nos-bbs] JNOS 2.0k.3B compiling issues

Langelaar maiko at pcsinternet.ca
Thu Sep 26 15:20:30 EDT 2019

Hi Ed,

Seems Ubuntu 19.04, latest Arch, and a few others are
basically telling people that setkey is obsolete, meaning I
need to get my butt in gear and try to compile this on a
more recent setup, it's been a while to be honest.

Sorry about that, I will get to it ASAP, just been very busy.

The only workaround is to #undef B2F in your config.h,
and then remove the '-lcrypto -lcrypt' from Makefile.

Maiko / VE4KLM

On 09/26/2019 02:09 PM, Ed Coates wrote:
> Hi everyone!
> I'm trying to compile  JNOS on a Virtualbox VM running Ubuntu 19.04.  
> I've rsync'd the JNOS source code and copied the files from the 2.0k.3 
> directory into the main directory and compiled it.  I originally ran 
> into some problems when it was compiling the tun.c file.  I found an 
> thread last month from Maiko that listed an alternate tun.c file to 
> use and that worked, but at the end of the compile, while it's linking 
> the binary jnos, I run into this error
>  gcc -DUNIX -g3   -DDEBUG -Wall -o jnos main.o config.o version.o 
> session.o \
> jheard.o clients.a servers.a hfdd.a net.a internet.a net.a netrom.a \
> unix.a ax25.a aprs.a dump.a ppp.a bootp.a inp.a j2curses.a \
> -lncurses  -lcrypto -lcrypt
> /usr/bin/ld: net.a(j2pwrtns.o): in function `j2setkey':
> /usr/src/jnos/j2pwmgr/j2pwrtns.c:68: undefined reference to `setkey'
> /usr/bin/ld: net.a(j2pwrtns.o): in function `j2userpasswd':
> /usr/src/jnos/j2pwmgr/j2pwrtns.c:185: undefined reference to `encrypt'
> collect2: error: ld returned 1 exit status
> make: *** [makefile:156: jnos] Error 1
> any ideas on the cause of the issue and how to fix it?
> Thanks,
> Ed
> _______________________________________________
> nos-bbs mailing list
> nos-bbs at lists.tapr.org
> http://lists.tapr.org/mailman/listinfo/nos-bbs_lists.tapr.org

More information about the nos-bbs mailing list