[nos-bbs] JNOS 2.0k.3B compiling issues

Ed Coates edcoates at gmail.com
Thu Sep 26 15:09:48 EDT 2019

Hi everyone!

I'm trying to compile  JNOS on a Virtualbox VM running Ubuntu 19.04.  I've
rsync'd the JNOS source code and copied the files from the 2.0k.3 directory
into the main directory and compiled it.  I originally ran into some
problems when it was compiling the tun.c file.  I found an thread last
month from Maiko that listed an alternate tun.c file to use and that
worked, but at the end of the compile, while it's linking the binary jnos,
I run into this error

 gcc -DUNIX -g3   -DDEBUG -Wall -o jnos main.o config.o version.o session.o
jheard.o clients.a servers.a hfdd.a net.a internet.a net.a netrom.a \
unix.a ax25.a aprs.a dump.a ppp.a bootp.a inp.a j2curses.a \
-lncurses  -lcrypto -lcrypt
/usr/bin/ld: net.a(j2pwrtns.o): in function `j2setkey':
/usr/src/jnos/j2pwmgr/j2pwrtns.c:68: undefined reference to `setkey'
/usr/bin/ld: net.a(j2pwrtns.o): in function `j2userpasswd':
/usr/src/jnos/j2pwmgr/j2pwrtns.c:185: undefined reference to `encrypt'
collect2: error: ld returned 1 exit status
make: *** [makefile:156: jnos] Error 1

any ideas on the cause of the issue and how to fix it?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20190926/cad82357/attachment.html>

More information about the nos-bbs mailing list