[nos-bbs] 2.0k hangs

Michael Fox - N6MEF n6mef at mefox.org
Tue Aug 9 00:59:49 EDT 2016

I'm getting hangs (JNOS doesn't crash, it just freezes), running 2.0k.  If I
kill it and restart, it will soon hang again.  If I revert to 2.0j.7v
instead, no hang.


The problem appears on several machines with nearly identical configurations
(except for the obvious required differences like call signs, ip addresses,
etc.).  It seems to be related to sending smtp mail.  When it occurs, there
are a bunch of emails in the smtp list queue.  SIGHUP and SIGINT have no
effect.  SIGINT will kill it.  After JNOS is restarted, I check smtp list
and I see a bunch of mails.  If I run smtp kick, it immediately hangs.  This
has happened multiple times over the last two days after switching to 2.0k


The workaround was to stop JNOS 2.0k and start up 2.0j.7v instead.  After
that, JNOS worked its way through the backlog like normal.  So I rolled back
my production machines to 2.0j.7v.  Of course, that means no B1F telnet


Now, how do I find the problem?


My understanding is that gdb needs a crash to produce useful output; a hang
won't work.  Correct?  

If so, what's the recommendation for finding the problem?








-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20160808/82dfdd0b/attachment.html>

More information about the nos-bbs mailing list