[nos-bbs] JNOS bbs messages

Michael E Fox (N6MEF) n6mef at mefox.org
Mon Mar 2 17:05:32 EST 2015

Hi Adam,


Without specific details, it could be anything.  Here are some thoughts:


You do need to start smtp.

I presume you do need a rewrite file.  (I've never tried it without one.)
The rewrite file format is documented in the manual.


The correct BBS command is "sp", but I guess "s" might also work.  


The web site you referenced deals with JNOS and a custom GUI front-end and a
local mail client.  You should eliminate variables and focus just on
command-line JNOS until you are sure you can reliably send/receive at the
JNOS mailbox prompt.


RE rewrite:

This file tells JNOS how to interpret (and optionally rewrite) various

You can test what it does at the JNOS *console* prompt (jnos>).

Type:  rewrite w8dev

You should get:  to: w8dev

If you do, then rewrite is working o.k. for local address.

If, instead, you get something else, then your rewrite file needs work
because it to putting messages into the wrong mailbox



To see what smtp has queued but not yet delivered, type this at the JNOS
*console* prompt (jnos>):  smtp list


Check the logs to see if you see anything wrong (i.e. errors):


<jnosdir>/logs/nos.log  (or DDMmmYY if you're using the old style log name)


Next, review your autoexec.nos and rewrite file vs. the manual to see if you
see any suspect lines.  (It's you're config.  You should understand it.)


Let us know what you find for all of the above.  If you still haven't
figured it out, you'll probably need to attach your autoexec.nos and rewrite






From: nos-bbs-bounces at tapr.org [mailto:nos-bbs-bounces at tapr.org] On Behalf
Of Adam De Lay
Sent: Monday, March 02, 2015 1:16 PM
To: nos-bbs at tapr.org
Subject: [nos-bbs] JNOS bbs messages


I recently got JNOS2.0j installed on my Raspberry Pi B+ with a TNC-Pi.  I've
been getting things figured out and I'm struggling to figure out how to
leave messages for other users on my BBS.  I've tried leaving a message for
myself using "s w8dev" and I get a message stating "message queued".  I
understand that JNOS uses areas, so I tried "s w8dev at w8dev" and I got the
same "message queued" message.  I've heard from several users that they're
unable to leave messages for me.  I've looked through dozens of pages trying
to figure out why.  I've seen other people that have had the same problem,
but no answer.  Some say you need to setup a rewrite file, so I tried that
with no luck.  Some say that you need to make sure that SMTP is started, and
it is.  


My autoexec.nos was generated using the JNOS config from


Any help would be greatly appreciated.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20150302/467f594a/attachment.html>

More information about the nos-bbs mailing list