[nos-bbs] Raspberry Pi Jnos Telnet from another PC problem

Jose Ng Lee hp2cwb at cwpanama.net
Mon Jan 27 11:35:46 EST 2014

I am using the F6BVP Raspbian image preinstalled with AX.25 and FBB, DXSpider, and FPAC working OK.

Uploaded the Jnos 2.0j and tried also 2.0jx4 sources to the Pi and compiled OK both jnos executable.

My problem is that I am not able to Telnet directly to the JNOS in the Raspberry PI from a PC.

I am able from the PC to Telnet first to the Linux side on the Raspberry Pi and then to the JNOS.

On my Full size PC with Ubuntu and JNOS, I can Telnet OK from a PC directly to JNOS.  I copy the autoexec.nos from my PC Ubuntu JNOS to the Raspberry Pi and changed some lines with the different IPs, etc..

On Jnos side, the tun0 is setup as usual:

# NOS creates the TUN device, so NOS needs to do a postcofig
shell ifconfig tun0 pointopoint mtu 1500 up
pause 5
shell arp -s b8:27:eb:e1:b2:ee pub

The ax25-up script already do:
echo 1 > /proc/sys/net/ipv4/ip_forward

Also, later checked and did "more ip_forward" and has the "1".

Checked from both the PC Ubuntu Jnos and Raspberry pi Jnos, With Webmin the network interfaces, routes, hostnames.  Also, checked on the command line from both machines de ARP and it looks OK for both.

Tried other things with no luck.  Looks like the RPI not able to do the IP to IP forwarding through the tun0 from an outside PC Telnet connection.

Has anyone got their Raspberry Pi with Jnos setup right and be able to Telnet directly from a PC.

73s Jose / HP2AT
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20140127/6376a9b3/attachment.html>

More information about the nos-bbs mailing list