[nos-bbs] RIP configuration woes

Michael E. Fox - N6MEF n6mef at mefox.org
Tue Nov 5 15:56:28 EST 2013


Thanks for the reference.  But still no joy.

In config.h, I have:
#define RIP
#undef RIP98

I have JNOS RIP configured with:

rip reject 1 (accept only v2)
start rip

On the tun0 interface, I have linux ( sending a single route
( to the unicast address of the JNOS end of tun0 (
I can see the route going out from linux properly using tcpdump.

In JNOS, "rip trace 2" shows:

	RIPCMD_RESPONSE from [] domain 0
	Route is not ipip - ignore type 0 (for now)

... each time it receives the RIP update from Linux.

So JNOS is seeing the RIP update and the route being received is correct.
But apparently, JNOS won't accept it because it's not an IP/IP route, even
though RIPAMPRGW is #undef'd.  (I double checked.  I even made another
build, just to be sure).
The route does not appear into the JNOS routing table.

I tried:  "rip accept" (linux address on the other end of tun0).
It shouldn't matter since no addresses has been "rip refuse" 'ed.  But I
tried it anyway.  No difference.

I tried:  "rip reject 0" (accept any version of RIP - not good, but tried it
anyway).  No difference.

I tried building with #define RIP98.  No difference.  And, apparently, RIP98
is a completely different protocol for use over RF.  See:

Could it be that the code assumes any routes coming in via the tun0
(non-radio) interface must be IP/IP routes?  Dumb assumption.  But maybe?

Any other suggestions?

Thanks for your help,

-----Original Message-----
From: nos-bbs-bounces at tapr.org [mailto:nos-bbs-bounces at tapr.org] On Behalf
Of Maiko Langelaar
Sent: Tuesday, November 05, 2013 8:37 AM
To: TAPR xNOS Mailing List
Subject: Re: [nos-bbs] RIP configuration woes

Hi Michael,

Check this link out : RIP for NOS users (dated, but probably helpful)


I've never heard of quagga, so I looked it up, and I'm sure you're not
talking about the extinct subspecies of the plains zebra that lived in 
South Africa, I see it's a software routing suite. Never heard about
it before (till now) and certainly never used it before. Sorry.

The first thing I think you need to do is compile the RIP in JNOS as
it used to be long before any of this AMPR RIP stuff was implemented,
in other words, in your config.h, make sure RIPAMPRGW is #undef, and
that #define RIP (and possible #define RIP98) are there. I see refs
to RIP98 in some of the searchs I did for quagga. The bottom line,
don't use the RIPAMPRGW for this. The problem with that however is
you will not be able to use the AMPR rip stuff and you'll have to
go back to your encap.txt. I know, I know, should have been better
thought out, but anyways it's just the way it is right now.

> Accept RIP v2 updates on interface tun0 from linux quagga ripd
> Don?t accept RIP in on any other interface
> Don?t send RIP out on any interface

You'll have to play with this on your own. Get your JNOS into the
original RIP configuration as explained, and just start from there,
I don't know how conforming the implementation is, never used it.

> But no matter what I try, JNOS doesn't seem to listen

Of course ethreal/tcpdump/whatever should help you out.


nos-bbs mailing list
nos-bbs at tapr.org

More information about the nos-bbs mailing list