[nos-bbs] usb -> serial help..

jerome schatten romers at shaw.ca
Sat Dec 1 00:17:51 EST 2012

Bob et al..,.

The setup is exactly as you describe it. I am quite familiar with
Minicom, having used it quite a bit in the distant past in non-gui mode.
So, I've set the settings for terminal parameters to 9600 baud, 7E1. And
indeed the '*' is the autobaud character on the XL. I see some activity
on the little led on the converter, but see nothing on the minicom

Moreover... I just did the following test on two separate TNC's:

I found in the basement an old machine with ubuntu on it, and it had one
serial port. Direct 232 cable now between the tnc and the computer.
Brought up minicom and set it up as above. Absolutely the same response
-- nada. Tried the kam and an mfj1270. Same. Tried ttyS1 and ttyS0 --
same: Nothing prints to the screen

I bring up minicom with sudo each time because it won't work for a
normal user in ubuntu. I checked the permissions: the binary is 755. I
checked minicom.users: anyone can access all configurations. 

So... I think I've narrowed it down to Not the tnc; not the usb-serial
converter, but something I've missed in minicom. It's v.2.3. 

So what am I missing?


On Fri, 2012-11-30 at 20:13 -0500, Bob Tenty wrote: 
> If your KAM-XL is connected to that USB Serial converter you should
> set Minicom to ttyUSB0
> The kernel driver for your converter simulates a serial device.
> /dev/USB0 will be the serial port in linux to communicate with your
> tnc.
> From the menu (Ctrl-A Z) enter "O" and you get another menu
> with other options  and choose "Serial port Setup" from there
> you can change the serial device settings in Minicom.
> 73,
> Bob VE3TOK
> On 12-11-30 06:33 PM, jerome schatten wrote:
> > Recently I was forced to migrate to a computer that has no serial port
> > for use with jnos and thus lost my radio drop.
> > 
> > When I plug in the converter, it is immediately recognized by linux
> > and /var/log/messages says it found a driver for the device and it is
> > now attached to /dev/ttyUSB0. 
> > 
> > With the tnc in kiss mode, I simply tried to see if it would auto-set up
> > and work with the old tnc kiss settings that worked last time around.
> > Nothing -- some packets were detected in kiss mode with bad headers...
> > etc.
> > 
> > I did a hard reset on the KAM-XL to bring it out of kiss mode so I could
> > test to see if a terminal programme (minicom) could talk to the TNC in
> > normal (non-kiss) mode.
> > 
> > And that is where I am stuck... What port on the 232 end of the cable
> > should I set Minicom for?  I thought it would be something like ttyS0,
> > S1... etc. Nada...   Minicom comes up and says it's port is /dev/tty8. I
> > tried that and likewise nada. 
> > 
> > Maybe I'm going about this the wrong way, but I figured I need to find
> > out if for sure if the converter is actually working first and then
> > worry about jnos.
> > 
> > Is there something else other than minicom that I should be using?
> > 
> > Any suggestions on how to proceed would be welcome.
> > 
> > Thanks,
> > jerome - ve7ass
> > 
> > 
> > 
> > 
> > _______________________________________________
> > nos-bbs mailing list
> > nos-bbs at tapr.org
> > https://www.tapr.org/cgi-bin/mailman/listinfo/nos-bbs
> _______________________________________________
> nos-bbs mailing list
> nos-bbs at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/nos-bbs

More information about the nos-bbs mailing list