[nos-bbs] headless jnos consuming 100% CPU

Harry Stone harrystone at gmail.com
Tue Mar 22 01:46:23 EDT 2011

It's definitely not a case of the tnc being disconnected, I can log in as
root, start jnos in the background and log out, and then ssh to the linux
box from another machine.  JNOS is still running, I can log in via the
tunnel interface and connect to another packet bbs but the cpu is getting

I had another problem with the TNC acting like it had a flow control
problem, it was squashing packets like the tnc was having an input buffer
overrun.  I never did get that working right, but I found a work-around.  I
think I have that fixed by configuring the TNC with a kernel ax.25 interface
and then using that interface in jnos with a baycom attach.  That also seems
to work fine, but a headless binary still consumes all cpu with otherwise
the same config.

I've also tried it with a soundcard modem and it works fine, but I haven't
tried the headless binary with it.

It's just weird.  It's not really a show stopper for me, but I thought Maiko
should know about it.  I emailed him today about it, he runs Slackware
himself so he's going to test it.

Having said all that, as a new ham and being new to JNOS and packet it's
still a nice piece of software.


On Mon, Mar 21, 2011 at 8:11 PM, George [ham] VerDuin
<k8rra at ameritech.net>wrote:

> Hi harry.
> On 03/21/2011 07:29 PM, Harry Stone wrote:
>> When I compile JNOS with headless defined, it compiles fine and also runs
>> fine until I start it and then log out of the machine.  After I log out,
>> JNOS consumes 100% of cpu.  It seems like it still runs fine, although the
>> machine is bogged down.
> I've not tried " define headless" since I like the option to
> connect/disconnect from the sysop console using screen to keep the I/O path
> alive.  For me, the "@" access to sysop functions is second best.  However I
> too have seen 100% just as you describe.  In my case I can demonstrate that
> some time after unplugging the TNC from the host, that the CPU does
> saturate.  Yes -- other responses continue OK / perhaps a little delayed.
> I've not determined where the infinite loop is, perhaps I should to make a
> stab at fixing the issue.  I *suspect* the issue for you is the same, and it
> is related to some buffer that will no longer empty to the device it is
> supposed to be driving.  Because the sysop console is very active I suspect
> the time to fill it up is shorter than my ttySx device, and worse > the
> headless option should stop filling the buffer.  And of course this
> paragraph is a WAG on my part. You should know that others on this reflector
> have reported "no saturation", even after disabling the TNC.
>> Is there a #define I can change in the config header to make it spit out
>> some debug info?  Please let me know if there's anything I can do to help
>> troubleshoot this.
> The gdb seems to be the preferred tool.  The standard jnos delivery
> includes whatever gdb needs for hooks and references.  They can be stripped
> out after you are happy if you need to save object module bytes.
> Best of luck
> Skip
> _______________________________________________
> nos-bbs mailing list
> nos-bbs at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/nos-bbs

Have old memories and young hopes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20110322/53d02dcb/attachment.html>

More information about the nos-bbs mailing list