[nos-bbs] Ubuntu 9.10 issues and tip....

Bob Tenty bobtenty at gmail.com
Tue Feb 16 04:32:00 EST 2010

Hi Chris,

I didn't experience that problem you have with Ubuntu  using a
standard  tnc.
Is this this not related to  the soundmodem software?
Maybe you can test it with a standard tnc.
Is not something  competing with soundmodem for sound access?



Chris wrote:
> So I've had some rather inconsistent issues with Ubuntu 9.10 using
> both the native linux ax.25 utlities and JNOS2.  All using the user
> space soundmodem utility compiled from latest.
> I had a 'sliding' window issue where the packet would either be
> foreshortened or cut off, regardless of some rather long experimental
> txdelay and txtail settings.  It feels like the OS is randomly
> delaying the generation of the packet data.  So the radio will key up
> but randomly either send the packet just fine, or cut it off on the
> beginning or the end of the packet.
> What I discovered is that on a clean system boot, a single bring up of
> the 'packet engine' as it were, everything works just great with
> either native linux utils or JNOS2.  I had been doing a lot of
> fiddling around so I had been bringing the soundmodem interface up and
> down multiple times on the same boot and swapping between the linux
> native mode and JNOS2.  I tried this with a start and stop script that
> both did and didn't unload and load the kernel modules with no
> difference in behavior.  Messing with ax.25 params on the fly didn't
> seem to make any difference either.
> I'm certain there weren't any double instances of anything running.
> The script checks for this and Ive manually checked for it.
> What the actual root cause is, I have no idea, but I've observed
> issues with this going back to Ubuntu 6.x releases and have not tried
> with any other distributions.  So I have no clue if it is peculiar to
> Ubuntu or not.  I just know that the easy solution is to simply only
> bring up packet ops once per boot session and reboot if I wish to swap
> anything around.
> If I just had to guess, I would guess that the ax.25 kernel modules
> are not really cleanly unloading even if lsmod is showing they have
> been removed.  Logically I'm not sure of any other reason that would
> cause this seeming loop in the timing of the packets.
> My soundcard hardware is a Tigertronics Signalink USB, though I doubt
> it is anything to do with that in and of itself.

More information about the nos-bbs mailing list