[nos-bbs] xNOS Web Based VNC/Mailbox/Whatever - try it out :)

George [Skip] VerDuin k8rra at ameritech.net
Thu Jul 9 09:19:10 EDT 2009

Isn't it kewl -- every new thing has at least one wrinkle Maiko [and 

Maiko Langelaar (ve4klm) wrote:
> Greetings to all,
> Here is my working prototype, >>SNIP<<
I'm in awe at the experimental response.
The full feature seems pretty close at hand.
> Point your browser to :
>    http://ve4klm.ampr.org:10000
My browser reports "Firefox can't establish a connection to the server 
at ve4klm.ampr.org:10000.".
I've seen this before and in previous attempts never got to the bottom 
of it -- like the rest of you have...:-)

SO -- I tried PING from the Linux command line.
The ICMP request looks good across tun interface, the response was 
"Unreachable host".
JNOS route table specifies to forward to the VHF interface -- 
it never did...:-(
SO -- I'm broken for the moment.

I also tried PING from the jnos BBS -- the IP address resolved OK.
Ping timed out with "no response".
OK - I see this as the second problem to fix after the one above.

> May not work for everyone, depending on your internet connectivity.
WELL -- in the past my ampr.net interface has worked well for traffic 
initiated by jnos.
I'm shocked at the failure today.
44... is passed over RF to my neighbor who has the encap via internet.
Here at K8RRA the traffic fails when traffic is initiated from the Linux 
stack of the jnos host.
The same result from anywhere on the LAN [as I expect].

It seems to me jnos has issued the wrong response to PING.
It seems jnos should have forwarded the ping request to my neighbor but 
it responded "unreachable".
It seems valid if the ICMP had been forwarded and generated the response 
"time-out / no response".
At the moment I don't see what I should fix.
> Maiko Langelaar / VE4KLM 
Isn't hamming fun?
Thanks in advance for considering this question.

More information about the nos-bbs mailing list