[nos-bbs] The UPLOAD command in sysop and user meu

(Skip) K8RRA k8rra at ameritech.net
Tue Apr 3 19:26:46 EDT 2007

HMMM Barry, all your questions cause me to re-read the document and help
I am left with the reality:
  1) UPLOAD does not perform it's task in accordance with my original
  2) so - WHERE in cyberspace is the content of <file> sent in response

On Tue, 2007-04-03 at 15:33 -0400, Barry Siegfried wrote:

> ["(Skip) K8RRA" <k8rra at ameritech.net> wrote]:
> > I believe to have stumbled into something like a bug...
> > Both myself and N1OXH are focusing on UPLOAD documentation detail.
> >
> > This is not the first time for the UPLOAD/DOWNLOAD subject on this
> > reflector in the past year.
> I recall a discussion about UPLOAD/DOWNLOAD on the mailbox menu.

The documentation change has worked out well.

> > The previous go-round worked itself out nicely with a change to
> > documentation and help files.
> > This time I favor a change to the jnos vocabulary.
> >
> > The sysop menu contains UPLOAD (but not DOWNLOAD) as an ascii
> > transport vehicle.
> When you say "sysop menu" are you talking about a human sitting
> at the net> prompt on the console, or are you talking about going
> to the remote net> prompt from inside a mailbox connection (for
> which you *do* normally need "sysop" privileges)?

Nope Barry - I'm talking about a terminal screen full of data not the
person reading it, and the consequence of issuing the command UPLOAD to
The prompt options are never "net>" but are:
  sysop: "...jnos>"
  user: "Area: k8rra (#3) >"
And the chain of commands leading to the jnos> prompt doesn't really

> > Usage is pretty clear as documented,

Boy - did I blow that observation...

>  but jnos does not perform as
> > documented on my host.
> > "UPLOAD FILE" gives error messages in the context of "DOWNLOAD"
> > errors.
> > "UPLOAD FILE" does not toggle into a mode of accepting ascii data
> > and placing it into a file.
> If you're talking about a human sitting at the net> prompt on the
> console, then UPLOAD means "send ASCII from a file to a session".

OK, so which session?  <session #> is not a parameter and the sysop
console supports many sessions simultaneously.  And to what purpose?
Like SOURCE command?

> I don't understand what you mean mean by "mode of accepting ascii
> data".
> The RECORD command implements a DOWNLOAD mechanism.

Not so much as RECORD supports a terminal stream "trace" mechanism.
Great for debugging research or for making examples of operation for
whatever purposes.
Rotten for file content host-to-host transfer.

AGAIN I make the same point for RECORD as I did for UPLOAD --> what
<session #> is recorded?

>  >>SNIP<<  I'm so confused.  :\

So - I was confused too.  Under those conditions you don't have a prayer
as staying on track...;-)

If you have real life proper (intended?) use examples for UPLOAD please
bring them on!


de [George (Skip) VerDuin] K8RRA k
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/nos-bbs_lists.tapr.org/attachments/20070403/7ea0846e/attachment.html>

More information about the nos-bbs mailing list