[nos-bbs] Confused KPC-3 KISS mode

wa7nwp wa7nwp at jnos.org
Sun Sep 17 13:30:33 EDT 2006

Everything was working great -- then I tried to fix it.

Went to add the "COMM" commands to automatically put my KPC3 into KISS 
mode for JNOS.  I had the param 255 setting in onexit.nos to take it out 
when JNOS shut down so it was only naturally that JNOS should start it up.

Of course I started out following the settings in "help comm" and that's 
apparently for the AEA or older KPC TNCS.  A few more bogus param 
commands later and my KPC3 is acting weird.   An outgoing ax25 connect 
transmits ok -- but the received packets coming back from the KPC3 to 
JNOS are apparently in some polled kiss mode.   JNOS trace shows a 
<polled> flag and 8 or so "." bytes before the data.   If tried the tnc 
commands for polled xkiss and checksummed xkiss but nothing seems to 
work.   I'm about to pop the case and do a hard reset -- pretty sure 
that will fix it.   Still I'm curious about what mode this is and if 
there is a way to fix it from the TNC command prompt.

It's strange there's no hard reset (that I can find) anymore from the 
command prompt.

Anybody have any suggestions here?

Bill - WA7NWP

More information about the nos-bbs mailing list