[nos-bbs] Re: AXUDP and APRS - configuring

Demetre Valaris sv1uy at ham.depa.gr
Sun Apr 17 03:42:22 EDT 2005

Andre v Schayk wrote:

> Demetre Valaris schreef:
>> Hi Bill,
>> This is what I use between my LINUX and Windows XP boxes in order to 
>> have DIGI_NED and javAPRS which run in the LINUX box talk APRS to AGW 
>> and UIview which run in the Windows XP box. These boxes are connected 
>> via Ethernet.
>> I run my APRS (UIview) locally not using TCP/IP but AX25 via the AXIP 
>> port. This is because I want my UIview to have a longer PATH than the 
>> javAPRS and this cannot be accomplished by using TCP/IP connection to 
>> the IGATE.
>> So here is my /etc/ax25ipd.conf that makes this configuration work.
>> socket udp 93
>> mode tnc
>> device /dev/ttyqf
>> speed 9600
>> loglevel 2
>> route sv1uy udp 93 d
>> 73 de Demetre SV1UY 
> Are you sure that d works? from what I remember of that ax25ipd code is
> that once it finds udp in the route command it nolonger checks for d and
> b resulting in only packets adressed to that call being send, I might be
> wrong but in my setup I had the callfilter code hacked so the call
> comparison was always valid.

Hi Andre,

Of course I am sure, I just copied the contents of  my 
/etc/ax25/ax25ipd.conf  to my previous e-mail and I remember I had a 
hell of a time to make it work with the instructions I had then.
If you check http://map.findu.com/sv1uy-3 you will see my UIview sending 
packets via this AXIP port Andre. On the PATH you will see that it 
passes from SV1UY-4 (my DIGI_NED having a pseudo AXIP port) and finally 
goes in APRS-IS via SV1UY-10 (my javAPRS IGATE). Works perfect and it 
has worked in all kernels of the 2.4.x series and also in kernels 2.6.x 
as well.

It wouldn't work for me with any other option! Probably this is the 
discrepancy that Bill was trying to resolve. My kernel is 2.4.29 and my 
AX25tools/AX25apps are the latest ones found in the net.

> 73 de Andre PE1RDW

73 de Demetre SV1UY
e-mail sv1uy at athnet.ampr.org

P.S. Bill if you are trying to work NETROM in kernel 2.6.x it is a waste 
of time. The machine crashes after a NETROM connect if you use LINUX  
node 0.3.2 or earlier. Keep you NETROM in JNOS if you use this kernel. I 
use 2.4.29 here.

More information about the nos-bbs mailing list