[hfsig] WsprryPi sends tone only for a few seconds

John C. Peterson jcp at eskimo.com
Wed Apr 18 03:10:14 EDT 2018

I had problems trying to use PiCW about a year ago. You didn't describe
what happened *after* transmission stopped, but in my case, the R-Pi froze
completely and required a cold reboot.

I had some spare time to look into it, and discovered some non-trivial
software related problems with PiCW that I was able to fix after some
lengthy detective work. (I don't think these problems were James' fault,
but appeared to have come from the new "mailbox" code for the Broadcom
PWM chip that came from another project).  My fork of PiCW with the
fixes is here;


The "plot thickens" is apropos at this point. One of the things the bad
code did was to *DELETE* the PWM device node and try to re-create it
(which it didn't do correctly among other problems).  I can't fathom
what the intended purpose of that was, but that's what was there!!! So
the bottom line is if you have ever (even once) run a version of PiCW
with this issue, your PWM device node has been trashed and you need a
fresh OS install to get back on track.

I posted a pull request to James' project page for my PiCW fork, but just
guessing he got busy (as I am now) and didn't see it. His version of PiCW
still has this issue that mangles your PWM device node, so caveat emptor!

At that time, I was using an older version of WsprryPi that was working
fine, but later discovered James' newest version had the same issues as
PiCW. I created a fork of WsprryPi with the same fixes that James has
since merged into his master branch. So his latest WsprryPi should be
good to go...

I'm guessing that James' latest WsprryPi will work fine on a *fresh*
install of the OS (just don't use his PiCW!).  You mentioned you were
using a Stretch (Debian 9) based distro, and I have not tested that. So
if that does not work, it's possible there has been some new regression
with the PWM mailbox driver in the Stretch distros. In that case,
I would try an older Jessie or Wheezy based distro for your R-Pi...

P.S. Your TAPR Wspr-Pi shield is probably just fine. The shield isn't even
required to run WsprryPi (a suitable BP filter is ...) I experimented
with it for a close to a year using my own filters before the shield
was even available.

On Tue, Apr 17, 2018 at 04:32:47PM -0500, John wrote:
> Simon,
> I assume you're aware of the github page: https://github.com/JamesP6000/PiCW
> You might try contacting James direct.  I don't think he monitors
> this mailing list.
> Zoltan, do you think HA7ILM would be able to help?  He seems to have
> contributed to the project.
> On 4/17/2018 4:14 PM, Simon Quellen Field wrote:
> > > Have you tried running PiCW without the WSPR board connected?
> >>HA7DCD
> >???> ???
> >Zoltan
> >
> >It did not occur to me until you suggested it.
> >I attached a wire to GPIO04 (GPIO_GCLK) Pin 7, and ran PiCW.
> >
> >I got the same results -- the first few characters were sent, then nothing.
> >
> >I then broke up my test message, so I could call PiCW with one
> >latter at a time, with a sleep 1 between calls.
> >Many of the letters got through, but perhaps a quarter of them were silent.
> >
> >These test seem to rule out problems with the card itself, and
> >seem also to rule out problems with the PiCW program.
> >
> >Suspecting the NTP corrections might be short-circuiting some
> >code, I tried PiCW with the -n option, which is supposed to
> >turn off NTP self-calibration. The program returned an error
> >message, saying that there was no -n option.
> >
> > ?? ??root at wsprpi:/home/pi/PiCW# PiCW -n -w 20 -f 14097000
> > ?? ??Detected Raspberry Pi version 2/3
> > ?? ??PiCW: invalid option -- 'n'
> > ?? ??root at wsprpi:/home/pi/PiCW#
> >
> >I found the problem in the code (the call to getopt_long did not
> >have an 'n' in the character string) and fixed that bug,
> >but using the -n option did not fix my original problem.
> > ?? ?? root at wsprpi:/home/pi/PiCW# PiCW -n -w 20 -f 14097000 "AB6NY
> > ?? ?? Detected Raspberry Pi version 2/3
> > ?? ?? PiCW parsed command line options:
> > ?? ?? ?? TX frequency: 14.097000 MHz
> > ?? ?? ?? WPM: 20
> > ?? ?? Message to be sent:
> >
> >
> >Then I tried "dit mode" where the -d option is supposed to send an
> >endless string of dits.
> > ?? ?? PiCW -d -w 20 -f 14097000
> >I was encouraged when I heard a good 20 seconds or so of dits, but
> >then it went silent again.
> >
> >Then I tried the test-tone option.
> > ?? ?? root at wsprpi:/home/pi/PiCW# PiCW -t -f 14097000
> > ?? ?? Detected Raspberry Pi version 2/3
> > ?? ?? PiCW parsed command line options:
> > ?? ?? ?? TX frequency: 14.097000 MHz
> > ?? ?? ?? NTP will be used to periodically calibrate the transmission frequency
> > ?? ?? Will transmit continuous tone on requested frequency. CTRL-C to exit.
> > ?? ?? ??Exiting with error; caught signal: 2
> > ?? ?? Exiting with error; caught signal: 11
> > ?? ?? ^Croot at wsprpi:/home/pi/PiCW#
> >
> >Whether I use the Raspberry Pi 3 Model B+ or the new Raspberry Pi
> >3 Model B v1.2, I get similar
> >results. The timing of the length of the transmissions seem to be
> >random. One time the -t option
> >emitted a tone for over 10 seconds. The very next time I tried it
> >the tone lasted only 4 seconds. The
> >third time I got no tone at all. The fourth time the tone lasted 7 seconds.
> >
> >All of these last tests were done without the card in place, just
> >with a 3 foot wire antenna on pin 7.
> >
> >Has anyone tested PiCW or WsprryPi on the latest Raspian NOOBS?
> >
> >I've tried it with WiFi turned off -- same result.
> >
> >Could the Pi be trying to use the clock for sounds at random times?
> >I am not hearing any sounds, but I don't know how to ensure that
> >they don't happen.
> >
> >
> >
> >
> >-----
> >Get a free science project every week! "http://scitoys.com/newsletter.html"
> >
> >
> >
> >_______________________________________________
> >hfsig mailing list
> >hfsig at tapr.org
> >http://www.tapr.org/mailman/listinfo/hfsig
> >
> -- 
> Sarcasm, just one of the many services I offer.
> John, W9DDD
> _______________________________________________
> hfsig mailing list
> hfsig at tapr.org
> http://www.tapr.org/mailman/listinfo/hfsig

John C. Peterson, KD6EKQ DM12ju
mailto:jcp at eskimo.com
San Diego, CA U.S.A

More information about the hfsig mailing list