[hfsig] WsprryPi sends tone only for a few seconds

Simon Quellen Field sfield at scitoys.com
Thu Apr 12 18:59:56 EDT 2018

Some more information.

I built the PiCW program, and ran it.
It sent the first few characters of the message, and then the output
stopped, even as the program kept slowly printing out the rest of the
I ran the test many times.
Sometimes there was no output at all.
Other times it would get as far as 10 or 12 characters before going silent.

To remove the antenna and ground from consideration, I replaced them with a
50 ohm dummy load between the antenna and ground connectors on the board.
I could hear the characters using a nearby receiver, but they still went
silent, usually after single digit numbers of characters had been sent.

The two programs (WsprryPi and PiCW) share many components, both in
software, and (of course) in hardware.
There could be a problem with the board.
There could be a change in the operating system that makes the programs no
longer work properly.

I have tried the board on several different Pi boards, both 3B and 3B+,
with the same results.
I have tried the programs with a network connection and without.
I made sure the computer was not trying to make sounds (the sound software
uses the same hardware as the WSPR board does).

I am beginning to think there is a problem with the WSPR board.
Before I buy another one to test that theory, I'd like to hear suggestions
from this SIG.

Get a free science project every week! "http://scitoys.com/newsletter.html"

On Thu, Apr 12, 2018 at 11:05 AM, Simon Quellen Field <sfield at scitoys.com>

> I am running WSJT-X on a receiver a couple feet from the RPi, and I can
> see (and hear) the beautiful tone
> from the radio and in the waterfall, but the tone stops after only a few
> seconds, despite the program thinking
> that it is still transmitting.
> I first tried it on my newest Pi 3 B+, and thought that maybe it was the
> faster processor confusing things,
> but when I went to an older Pi 3 B, I got the same results. The duration
> of the tone is variable, sometimes
> only a second or two, and sometimes as long as 10 or 15 seconds. But never
> long enough to send the whole
> message.
> This is on a new SD card, with today's Raspian Stretch built from NOOBS,
> following the instructions:
> sudo apt-get update
> sudo apt-get dist-upgrade
> sudo apt-get install git
> git clone https://github.com/JamesP6000/WsprryPi.git
> cd WsprryPi
> make
> My command line was:
> sudo ./wspr -r -o -s AB6NY CM87xe 20 20m
> Does this sound like a problem with the board?
> ​Or is there a known problem with the latest software?
> I've read through the source code, and there isn't anywhere that aborts a
> transmission early.
> The program thinks it is still transmitting for the whole 110.686 second
> transmit window.​
> The shortest transmission printout on the screen is 110.669 seconds, and
> the longest was
> 110.688 seconds. But the tone in the receiver only lasts 5 seconds on
> average.
> -----
> Get a free science project every week! "http://scitoys.com/newsletter.html
> "
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/hfsig_lists.tapr.org/attachments/20180412/284ebdc9/attachment.html>

More information about the hfsig mailing list