[aprssig] Help needed: APRS receive with RTL_SDR and Direwolf

spam8mybrain spam8mybrain at yahoo.com
Sat Aug 17 07:48:04 EDT 2019

Hi, Greg.
One of the users of my software pulled this stunt to use an RTL_SDR dongle. See if this (with appropriate adjustments) works for you.https://blog.pwarren.id.au/tech/2014/02/11/APRS-to-YAAC.htmlI make no guarantees; I haven't tried it myself yet.Andrew, KA2DDOauthor of YAAC

-------- Original message --------
From: Greg D <ko6th.greg at gmail.com> 
Date: 8/12/19  00:42  (GMT-05:00) 
To: TAPR APRS Mailing List <aprssig at lists.tapr.org> 
Subject: [aprssig] Help needed: APRS receive with RTL_SDR and Direwolf 

Hi folks,I'm trying to set up a "quick" receive iGate with a Raspberry Pi, anRTL_SDR dongle, and Direwolf.  No joy as yet.  However, when I run theSDR dongle as a server with rtl_tcp and aim GQRX at it with its internalpacket decoder tool, that decodes just fine.  Direwolf also works finewith a USB sound card and a cell phone mike near my HT, so I'm guessingthe issue is with rtl_fm.  What setting have I bungled or missed indoing this?The run string I'm using is this, or variations on the theme (I've trieda bunch of different stuff, without luck).$ rtl_fm -f 144.39M -M nbfm -E offset 0 -g 11 -p 60 -r 24000 - |direwolf -c direwolf.sdr.conf -r 24000 -p -D 1 -Here's what it displays.  Note the error from line 155 also is seen whenrunning Direwolf from a sound card, and that decodes just fine, so Idon't think it's a problem with the Direwolf config.  And, yes, it is anold version of Direwolf, but for reasons too convoluted to go into here,that's what I've got.Dire Wolf version 1.0aLine 155: Missing tone frequency for space.Audio input device for receive: stdinAudio out device for transmit: nullFound 1 device(s):  0:  Generic, RTL2832U, SN: 77771111153705700Using device 0: Generic RTL2832UChannel 0: 1200 baud, AFSK 1200 & 2200 Hz, A, 24000 sample rate.Note: PTT not configured for channel 0.Virtual KISS TNC is available on /dev/pts/0WARNING - Dire Wolf will hang eventually if nothing is reading from it.Created symlink /tmp/kisstnc -> /dev/pts/0Ready to accept KISS client application on port 8001 ...Ready to accept AGW client application on port 8000 ...Found Rafael Micro R820T tunerTuner gain set to 12.50 dB.Tuner error set to 60 ppm.WARNING: Failed to set offset tuning.Tuned to 144390000 Hz.Oversampling input by: 42x.Oversampling output by: 1x.Buffer size: 8.13msExact sample rate is: 1008000.009613 HzSampling at 1008000 S/s.Output at 24000 Hz.Now connected to IGate server noam.aprs2.net ( server status here[ig] # aprsc 2.1.4-g408ed49<0x0d><0x0a>[ig] # logresp KO6TH-8 verified, server T2BC<0x0d><0x0a>[ig] KO6TH-8>APDW10:!3857.53N\12106.64W&and nothing after that...  Even with my TH-D74 in the same room, on ELpower so as to not crush the input._______________________________________________aprssig mailing listaprssig at lists.tapr.orghttp://lists.tapr.org/mailman/listinfo/aprssig_lists.tapr.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tapr.org/pipermail/aprssig_lists.tapr.org/attachments/20190817/a61fb60c/attachment.html>

More information about the aprssig mailing list