[aprssig] Help needed: APRS receive with RTL_SDR and Direwolf

Greg D ko6th.greg at gmail.com
Mon Aug 12 00:42:16 EDT 2019

Hi folks,

I'm trying to set up a "quick" receive iGate with a Raspberry Pi, an
RTL_SDR dongle, and Direwolf.  No joy as yet.  However, when I run the
SDR dongle as a server with rtl_tcp and aim GQRX at it with its internal
packet decoder tool, that decodes just fine.  Direwolf also works fine
with a USB sound card and a cell phone mike near my HT, so I'm guessing
the issue is with rtl_fm.  What setting have I bungled or missed in
doing this?

The run string I'm using is this, or variations on the theme (I've tried
a bunch of different stuff, without luck).

$ rtl_fm -f 144.39M -M nbfm -E offset 0 -g 11 -p 60 -r 24000 - |
direwolf -c direwolf.sdr.conf -r 24000 -p -D 1 -

Here's what it displays.  Note the error from line 155 also is seen when
running Direwolf from a sound card, and that decodes just fine, so I
don't think it's a problem with the Direwolf config.  And, yes, it is an
old version of Direwolf, but for reasons too convoluted to go into here,
that's what I've got.

Dire Wolf version 1.0a
Line 155: Missing tone frequency for space.
Audio input device for receive: stdin
Audio out device for transmit: null
Found 1 device(s):
  0:  Generic, RTL2832U, SN: 77771111153705700

Using device 0: Generic RTL2832U
Channel 0: 1200 baud, AFSK 1200 & 2200 Hz, A, 24000 sample rate.
Note: PTT not configured for channel 0.
Virtual KISS TNC is available on /dev/pts/0
WARNING - Dire Wolf will hang eventually if nothing is reading from it.
Created symlink /tmp/kisstnc -> /dev/pts/0
Ready to accept KISS client application on port 8001 ...
Ready to accept AGW client application on port 8000 ...
Found Rafael Micro R820T tuner
Tuner gain set to 12.50 dB.
Tuner error set to 60 ppm.
WARNING: Failed to set offset tuning.
Tuned to 144390000 Hz.
Oversampling input by: 42x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 24000 Hz.

Now connected to IGate server noam.aprs2.net (
Check server status here

[ig] # aprsc 2.1.4-g408ed49<0x0d><0x0a>
[ig] # logresp KO6TH-8 verified, server T2BC<0x0d><0x0a>
[ig] KO6TH-8>APDW10:!3857.53N\12106.64W&

and nothing after that...  Even with my TH-D74 in the same room, on EL
power so as to not crush the input.

More information about the aprssig mailing list